Supported Mac OS versions

Pixellu SmartAlbums 2 supports the following Mac OS versions:

  • 10.10 (Yosemite)
  • 10.11 (El Capitan)
  • 10.12 (Sierra)
  • 10.13 (High Sierra)

Still need help? Contact Us Contact Us